This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.
  1. We are after as many aquarium plant images that we can get, doing so will assist us in completing the aquarium plant database.

    https://barrreport.com/threads/aquatic-plant-images-wanted.14374/
    Dismiss Notice

Surface "oil Spill" After Fertilizing

Discussion in 'Fish for Planted Tanks' started by yd2, Aug 13, 2020.

  1. yd2

    yd2 New Member

    Joined:
    Aug 12, 2020
    Messages:
    5
    Likes Received:
    1
    Local Time:
    8:36 PM
    B"H

    hello
    I bought API leaf Zone and found it's missing Nitrogen & Phosphorus so i got both of this from Seachem .
    and i use recommended dosing, i didn't poured it to the tank directly but
    take a water from the tank & mix all 3 fert's in a cup, and slowly pouring it back to the tank.

    but after about 24 hours the tank top is resembling an OIL SPILL! upload_2020-8-13_20-32-59.gif
    is that typical & to be expected from fert's?

    also i noticed some of the neon tetra's lower rear fin tip turned a while back white on some of them.
    but could that be the start of fin rot & related to the fert's chemicals i've used?
    thank you.

    best regards
    Yaron
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice