This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.
  1. We are after as many aquarium plant images that we can get, doing so will assist us in completing the aquarium plant database.

    https://barrreport.com/threads/aquatic-plant-images-wanted.14374/
    Dismiss Notice

Stupid mistake, green water + uv

Discussion in 'General Plant Topics' started by discocarp, Aug 14, 2005.

  1. discocarp

    discocarp Junior Poster

    Joined:
    May 31, 2005
    Messages:
    8
    Likes Received:
    0
    Local Time:
    9:02 AM
    Stupid. Stupid. Stupid. I've been experimenting with a non CO2 tank and for the most part it was going well. I got a bad case of green water though, and went out to pick up a uv sterilizer. Back ordered of course. Finally got it a couple days ago, hooked it up, kills the green water great. 2 days later and its MUCh improved.

    Here comes the stupid part. I can't believe I did this. I hooked it up and ignored the tank for a couple days. Of course all that rotting green water polutes the tank. Lost all my amanos and my rubbernose. :( Did a 75% WC today, will keep up with 20% for a week or so til I get things back on track. I don't know what I was thinking. I should of done the big WC first, then run the UV. Remove most of it before it rots in the tank.

    Oh well. Its not the first time I've been a moron and won't be the last I'm sure. Just needed to vent someplace where people might understand.
     
  2. Tom Barr

    Tom Barr Founder
    Staff Member Administrator

    Joined:
    Jan 23, 2005
    Messages:
    18,673
    Likes Received:
    623
    Local Time:
    9:02 AM
    Re: Stupid mistake, green water + uv

    I've done this without a problem but the Green water would have to be fairly dense for this to occur.
    It's possible, though..........I'd look for other reasons.

    Regards,
    Tom Barr
     
  3. discocarp

    discocarp Junior Poster

    Joined:
    May 31, 2005
    Messages:
    8
    Likes Received:
    0
    Local Time:
    9:02 AM
    Re: Stupid mistake, green water + uv

    It was *really* dense. I waited for the uv (backordered) too long. I'm pretty positive this is the case, Ammonia tested off the scale, and the water stunk like a rotting mess when I did the water change. I'm pretty sure everything was ok before, and lost a lot of stuff right after adding the uv. Nothing else in tank has changed.

    Any other ideas on what I should look for? I am pretty sure it was this, but I definately would like to be sure. I don't see what else could of driven ammonia up that fast that quick.
     
  4. discocarp

    discocarp Junior Poster

    Joined:
    May 31, 2005
    Messages:
    8
    Likes Received:
    0
    Local Time:
    9:02 AM
    Re: Stupid mistake, green water + uv

    Well, rodi tested off the scale for ammonia too, so I guess that test kit is garbage. :p

    Still no clue what happened, green water die off is still my guess. Everything is looking much better today.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice