This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.
  1. We are after as many aquarium plant images that we can get, doing so will assist us in completing the aquarium plant database.

    https://barrreport.com/threads/aquatic-plant-images-wanted.14374/
    Dismiss Notice

Not getting rid of the diatoms (if they are diatoms). help needed.

Discussion in 'Aquascaping' started by Omegatron, Jun 11, 2013.

  1. Omegatron

    Omegatron Guru Class Expert

    Joined:
    Mar 24, 2013
    Messages:
    107
    Likes Received:
    2
    Local Time:
    12:44 PM
    Hi,

    in february I tried a new scape, shortly after the startup of the tank it got infested with diatoms. Thanks to Tom Barr I managed to get rid of them by doing a waterchange of 50% 3 times a week. After 2 weeks it was gone.

    Though in april i realized i wasnt happy with the rock formation and decided to change it. Meaning: moving the substrate and stones and replanting everything. I think a week or so after this, the diatoms reappeared. Now almos 8 weeks after rescaping the diatoms are still there. I have been very strict with the water changes. I add Easylife Carbo and I also am using pressurized CO2 and the EI method.

    I took some pictures to visualize what am dealing with. Since im not able to get rid of them i wonder if these are diatoms. Im getting really 'depressed' at the moment. After rescaping the tank never trived.

    Maybe this is also important but i have a lot of tiny worms in my substrate and those worms are always on the brown/black stuff (diatoms?). i have been reading into the planaria but i dont think this is planaria. these are way smaller (if you dont look for them you wont see them) and dont have a head like planaria. These worms should be very common and are no thread whasoever (from what ive read on the internet)

    Do you kind people have any tips for me what to do? What am i dealing with and why wont it go away.

    Here are the pics.

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    Thank you very much for all your help!!
     
  2. Tom Barr

    Tom Barr Founder
    Staff Member Administrator

    Joined:
    Jan 23, 2005
    Messages:
    18,692
    Likes Received:
    716
    Local Time:
    12:44 PM
    Looks more like a CO2 issue at some point led to a die back of the HC.
     
  3. Omegatron

    Omegatron Guru Class Expert

    Joined:
    Mar 24, 2013
    Messages:
    107
    Likes Received:
    2
    Local Time:
    12:44 PM
    Hi Tom thanks for responding, the color is exactly the same as before, thats why i thought it was diatoms again.

    So i should try cranking up the CO2? For a 190 liters tank (50 gallons) im at 2.2 bps i thought this was pretty high already.
    Im wondering because if I dont do a waterchange after the 2nd day i end up with a (almost) dead amano shrimp. I think because of the CO2 because when they arent doing well, as in almost dying, i do a quick waterchange and when the fresh water in the tank is in the amano shrimp is fine again. that made me think i have to much CO2 as it is now.

    You still recommend increasing the CO2?

    Im also using a UP atomizer and a Hydor wave pump to increase the flow through the tank.

    thanks!
     
  4. Tom Barr

    Tom Barr Founder
    Staff Member Administrator

    Joined:
    Jan 23, 2005
    Messages:
    18,692
    Likes Received:
    716
    Local Time:
    12:44 PM
    Clean the filter and the CO2 diffuser.
    Keep those very clean(every 2-4 weeks min).

    When you redo a tank and leave the plants in, sometimes you hurt the plants or do something that knocks everything off, so you have to do a lot more work to keep on it.
    I'd be careful with the CO2, but that's what the HC seems to be saying, you might need to trim it good also and see if the new growth comes back.
     
  5. Omegatron

    Omegatron Guru Class Expert

    Joined:
    Mar 24, 2013
    Messages:
    107
    Likes Received:
    2
    Local Time:
    12:44 PM
    Hi Tom,

    Thanks for the tip i will definatly clean the filter and diffusor more often, i didnt do that so often now.

    About cutting back the HC, i did this about 2 weeks ago, trimmed it really short to get rid of the brown stuff. As you can see on the pics, new growth came but the black brown stuff came back aswell.

    I ordered a new difusor on ebay, [​IMG]

    I am going to replace the atomizer with this one, maybe it gives better results then the atomizer since its comming from my spraybar now and the spraybar is 2 cm under the water surface, so i was thinking a lot of co2 escapes immidiatly to the surface.

    BTW how can i find out what is exactly going on now, i think its really difficult for you guys to see it on the pictures. Diatoms or dead plants....or whatever. Its so frustrating not knowing whats going on.

    If you have more tips let me know, ill keep updates in this thread.

    Thanks!
     
  6. Omegatron

    Omegatron Guru Class Expert

    Joined:
    Mar 24, 2013
    Messages:
    107
    Likes Received:
    2
    Local Time:
    12:44 PM
    Hi Tom,

    I investigated the HC a bit more. took a bunch out and i noticed that if i gently rub on a black HC leaf the black comes of and i can see the green again. So its not dead. Should it be diatoms after all then or some other sort of trouble?

    thanks
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice