This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. We are after as many aquarium plant images that we can get, doing so will assist us in completing the aquarium plant database.

    https://barrreport.com/threads/aquatic-plant-images-wanted.14374/
    Dismiss Notice

Kinda wierd...

Discussion in 'Aquatic Plant Fertilization' started by abcemorse, Feb 9, 2010.

  1. abcemorse

    abcemorse Prolific Poster

    Joined:
    Sep 8, 2008
    Messages:
    83
    Likes Received:
    0
    Local Time:
    1:04 PM
    Kinda of wierd thing with Plantex, I used to mix a stock solution that was a brown color when mixed and noticed after about 2-3 weeks it would turn more reddish, the color deepening over time. Also algae issues and lowsy growth. I stopped mixing stock solution and started dosing directly. Growth exploded and algae went away in 2 weeks. No other changes to the regimen. Anyone seen this before? Possible the stuff actually rusted and iron became unusable??
     
  2. Tug

    Tug Lifetime Charter Member
    Lifetime Member

    Joined:
    Jan 5, 2009
    Messages:
    1,150
    Likes Received:
    8
    Local Time:
    1:04 PM
    Just to rule out under dosing the premixed solution as the problem. How much Plantex did you mix into how much distiled water to make your stock and how much did you dose into what size water column? How much do you now dose of the dry? Did you add any HCL to the stock solution? Maybe something was growing in the bottle and using up some of the trace. What is interesting is that you would have this problem and others don't. I hope someone has an answer to this.
     
    #2 Tug, Feb 9, 2010
    Last edited by a moderator: Feb 9, 2010
  3. Philosophos

    Philosophos Lifetime Charter Member
    Lifetime Member

    Joined:
    Mar 12, 2009
    Messages:
    1,346
    Likes Received:
    0
    Local Time:
    1:04 PM
    Was the brown or red solution clear?

    When I use HCL to stabilize a CSM+B mix I get a deep rusty red color. I haven't had any problems with it though. Odds are a lower pH would help the iron more than harm it.
     
Loading...

Share This Page