This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. We are after as many aquarium plant images that we can get, doing so will assist us in completing the aquarium plant database.

    https://barrreport.com/threads/aquatic-plant-images-wanted.14374/
    Dismiss Notice

Help! Brown Algae Returns

Discussion in 'Aquatic Microbiology' started by Peter F, Aug 4, 2009.

  1. Peter F

    Peter F Junior Poster

    Joined:
    Jul 9, 2009
    Messages:
    4
    Likes Received:
    0
    Local Time:
    5:39 AM
    I am running a 180 litre heavily planted tank. The tank has been set up for over two months and has already passed through the brown algae stage for new tanks. However, after approximately five weeks of the brown algae being absent it has returned! Lighting, C02 and water changes have been constant throughout this period.

    From day one I have been dosing 5mls of Tropica Nutrition and after around two weeks I introduced Tropica capsules to feed the plant roots as I am using a plain gravel substrate. For the past three weeks I have been dosing Tropica Nutrition Plus at the same rate as before. Tropica Nutrition Plus contains Phosphates and I am wondering if this is the cause of my problem? However, the root capsules also contain Phosphates.

    My course of action has been to stop plant feeding and increase water changes, the plants are all still thriving but I don't know if this is the correct course of action? I am only guessing Phosphates and possible Silicates are the problem.

    I would appreciate any advice and guidance on what to do.

    Regards: Peter
     
  2. Philosophos

    Philosophos Lifetime Charter Member
    Lifetime Member

    Joined:
    Mar 12, 2009
    Messages:
    1,346
    Likes Received:
    0
    Local Time:
    5:39 AM
    As you'll most likely find, phosphates aren't your problem. Too many nutrients isn't your problem either. If anything too little and a lack of balance due to limitation is the issue.

    Get your self acquainted with your water column, and what needs to be in it for plants to grow. Here's a good start:

    http://www.barrreport.com/estimative-index/62-estimative-index-dosing-no-need-test-kits.html

    Aim for the nutrient levels listed here, figure out how you want to achieve them. The article gives you one method, but there are many ways to do it.

    At the same time, if silicates are the cause, find the source. Water quality reports are good, though substrate can also cause the issue.

    CO2 may still be an issue when you've got it all sorted; CO2 takes work. I've got a 28 gal that's about a week or two old now, and I'm still toying with distribution and maintaining proper levels despite having experience with it already.

    -Philosophos
     
  3. Biollante

    Biollante Lifetime Charter Member
    Lifetime Member

    Joined:
    Jun 21, 2009
    Messages:
    3,210
    Likes Received:
    1
    Local Time:
    5:39 AM
    Hi Peter,

    What Philosophos says.:D

    If silicates are the problem, even if you only strongly suspect silicates, I recommend you run a product like Chem-Pure Elite in your filter for a bit. Be careful about messing with the substrate, especially if you are using sand.

    Biollante
     
Loading...

Share This Page