This site is supported by the advertisements on it, please disable your AdBlocker so we can continue to provide you with the quality content you expect.
  1. We are after as many aquarium plant images that we can get, doing so will assist us in completing the aquarium plant database.

    https://barrreport.com/threads/aquatic-plant-images-wanted.14374/
    Dismiss Notice

Glosso with weird pale green. Please help me

Discussion in 'Aquatic Plant Species' started by thong123, Aug 2, 2015.

  1. thong123

    thong123 Junior Poster

    Joined:
    Jun 10, 2015
    Messages:
    47
    Likes Received:
    0
    Local Time:
    5:34 AM
    hi can someone please tell me what going on with my plants ?





    co2 + 39 w x 3 T5 ho


    2.5 Ft tank
     
  2. Solcielo lawrencia

    Joined:
    Mar 20, 2013
    Messages:
    1,007
    Likes Received:
    43
    Local Time:
    5:34 AM
    It's dying. Possible nutrient toxicity.
     
  3. thong123

    thong123 Junior Poster

    Joined:
    Jun 10, 2015
    Messages:
    47
    Likes Received:
    0
    Local Time:
    5:34 AM
    omg Mr. what should i so now ? Frequent water changes ? I dont to loose all my months work for the Glosso.
     
  4. Solcielo lawrencia

    Joined:
    Mar 20, 2013
    Messages:
    1,007
    Likes Received:
    43
    Local Time:
    5:34 AM
    I assume it's a new tank, uncycled, infrequent water changes...?
     
  5. thong123

    thong123 Junior Poster

    Joined:
    Jun 10, 2015
    Messages:
    47
    Likes Received:
    0
    Local Time:
    5:34 AM
    its a 2++ month old tank, should be cycled. I have not started any fert dosing, can it be the problem ?


    water change every 2 week or so


    tyvm Mr
     
  6. Solcielo lawrencia

    Joined:
    Mar 20, 2013
    Messages:
    1,007
    Likes Received:
    43
    Local Time:
    5:34 AM
    Did you test for ammonia? It's unlikely that a WC every 2 weeks or so will remove the excess ammonium and it's unlikely that the filter will have established sufficiently to process it into nitrate. Since it's Aquasoil, lack of additional fertz is unlikely to be the problem.
     
  7. thong123

    thong123 Junior Poster

    Joined:
    Jun 10, 2015
    Messages:
    47
    Likes Received:
    0
    Local Time:
    5:34 AM
    yes the first month the ammonia was crazy high, i did Wc every few days ..about 2 month the ammonia was already 0.


    All other plants are doing OK, except Glosso...i taken so picture of my tank for reference.


    i just did a trim on the Glosso and the 3rd pictures still shows the pale green color.


    Mr. please guide me in the right direction. Thx




    C360_2015-08-11-21-55-55-387.jpg

    C360_2015-08-11-21-57-05-907.jpg

    C360_2015-08-11-21-56-37-507.jpg
     
    #7 thong123, Aug 11, 2015
    Last edited by a moderator: Aug 11, 2015
  8. Solcielo lawrencia

    Joined:
    Mar 20, 2013
    Messages:
    1,007
    Likes Received:
    43
    Local Time:
    5:34 AM
    The ammonia is probably still high in the substrate.
     
  9. thong123

    thong123 Junior Poster

    Joined:
    Jun 10, 2015
    Messages:
    47
    Likes Received:
    0
    Local Time:
    5:34 AM
    ok Mr will do more WCs. thx and god bless
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice